NoobsPlanet

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics, posts and unlimited download to our resources, as well as connect with other members through your own private inbox!

Audio Conexant cx20632 micro support

Frade

New member
Hi guys!

Need some help here.

Successfully installed Mojave, Vanilla, Clover, on a HP Prodesk 400 G6 | Intel® B360 | i5-9500 | UHD 630

But I'm having trouble with Audio.
Codec: Conexant CX20632, using AppleALC, having audio but microphone doesn’t work.

I checked Hackintool, and have several profiles IDs, tried some, none worked for microphone.

What should do!?

Appreciate any help

Thanks
 

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Hi guys!

Need some help here.

Successfully installed Mojave, Vanilla, Clover, on a HP Prodesk 400 G6 | Intel® B360 | i5-9500 | UHD 630
Add this in your profile signature first:

But I'm having trouble with Audio.
Codec: Conexant CX20632, using AppleALC, having audio but the microphone doesn’t work.

I checked Hackintool, and have several profiles IDs, tried some, none worked for microphone.

What should do!?

Appreciate any help

Thanks
You should only check with the two IDs, i.e 23 and 28 only as your audio device support two layout-id for Hackintosh. Also, make sure you rebuild your kernel caches every time when you change it. If this also doesn't work then you need to patch your DSDT to make it work.
Also, make sure you doesn't have other audio kext installed in your machine.
 

Frade

New member
Hi! Thanks for your reply.
(Sorry the late response, been very busy).

You should only check with the two IDs, i.e 23 and 28 only as your audio device support two layout-id for Hackintosh.
I have 3 doors ( 3,5 jacks).
Two on the back (1 line in, 1 line out), the profile 28, only enables the line out one.
I'm using profile 23, which enables the front jack (out+in), but the problems is that only works for Audio, no microphone (in).

Also, make sure you rebuild your kernel caches every time when you change it.
I'm putting my kext on EFI/CLOVE/kexts/Other
Using AppleALC.kext (Lilu.kext, WhateverGreen.kext) for audio

If this also doesn't work then you need to patch your DSDT to make it work.
Sorry, don't know nothing about patching DSDT :rolleyes:

The links you send me are for Sierra, I'm using Mojave. Nevertheless will give it a look.

once more, Thank you
 
Top