NoobsPlanet

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics, posts and unlimited download to our resources, as well as connect with other members through your own private inbox!

DSDT Patch Request Here[For Laptop]

kuarahy

New member
Hello,
Thanks for your help in advanced
Laptop : Lenovo Ideapad S-145
CPU : Core i7-855U 4core 1.8ghz
GPU : Intel UHD 620 + nvidea geforce mx110 2gb
RAM : 12 GB DDR4
OS : MOJAVE 10.14.6 + Windows 10 64 bit
Wifi Card : I am using an USB TP link (working ok)

to intall mojave I used another lenovo ideapad 330 clover files, because I am not an expert in hackintosh.

From what I can tell , everything works but the
- trackpad (in system preferences there is no recognised trackpad at all)
- HDMI does not work, cant connect to external displays.
- function keys dont work except for the volume up and down keys
- the intel graphic says it is Intel UHD graphics 620 in "about this mac" but it only shows 7mb of video ram and there is not acceleration

Thanks for your help
 

Attachments

kuarahy

New member
correction
CPU i7-8565u
Hello,
Thanks for your help in advanced
Laptop : Lenovo Ideapad S-145
CPU : Core i7-855U 4core 1.8ghz
GPU : Intel UHD 620 + nvidea geforce mx110 2gb
RAM : 12 GB DDR4
OS : MOJAVE 10.14.6 + Windows 10 64 bit
Wifi Card : I am using an USB TP link (working ok)

to intall mojave I used another lenovo ideapad 330 clover files, because I am not an expert in hackintosh.

From what I can tell , everything works but the
- trackpad (in system preferences there is no recognised trackpad at all)
- HDMI does not work, cant connect to external displays.
- function keys dont work except for the volume up and down keys
- the intel graphic says it is Intel UHD graphics 620 in "about this mac" but it only shows 7mb of video ram and there is not acceleration

Thanks for your help
 

nexiamuel

New member
Hello, I need help to fix Battery (in verbose mode it say "ACPI Error: Method parse/execution failed [\_SB.AC.ADJP] (Node ffffff804edf4450), AE_NOT_FOUND") and turn off nvidia GPU (disable fan and gpu it self)

Spec :
Laptop Gigabyte Sabre 15
CPU : Intel i7-7700HQ
GPU : Intel HD 630 + Nvidia GTX 1050 (Mobile/Notebook)
RAM : 16GB DDR4
OS : MacOS Catalina + Windows 10
 

Attachments

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Hello, I need help to fix Battery (in verbose mode it say "ACPI Error: Method parse/execution failed [\_SB.AC.ADJP] (Node ffffff804edf4450), AE_NOT_FOUND") and turn off nvidia GPU (disable fan and gpu it self)

Spec :
Laptop Gigabyte Sabre 15
CPU : Intel i7-7700HQ
GPU : Intel HD 630 + Nvidia GTX 1050 (Mobile/Notebook)
RAM : 16GB DDR4
OS : MacOS Catalina + Windows 10
Please describe your problems in detail and mention what patches you have done on your DSDT? Explain clearly what you are trying to achieve?
 

nexiamuel

New member
Please describe your problems in detail and mention what patches you have done on your DSDT? Explain clearly what you are trying to achieve?
My problem is :
- Battery indicator works but when charging battery stuck and not showing charging logo (in this case using SMCBatteryManager.kext)
- My Nvidia fan is spinning and Feel Warm so i think my nvidia not disabled
- Sleep work with fn+f12 (sleep button) and Lid close but not with Apple logo -> sleep

I'm using DSDT from Github and modified with Fix IRQ Patch and Audio Inject Layout 40.
 

wolfgang

New member
Hello to everyone i'm glad to be there!!
I successfully installed Mojave 10.14.6 on laptop HD530 (HP Pavilion 15 bc000nv)
Working:
-Bluetooth
-Ethernet
-Audio(Speakers and Headphones)
-Sleep

Not Working:
-HDMI
-Battery charging

I hope to solve at least the problem with no charging!!

Thanks in advance!!


PS: I think when i tried to install hackintosh at Sierra i had the wifi icon on post installation but on mojave no wifi card was found
 

Attachments

Last edited:

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Hello to everyone i'm glad to be there!!
I successfully installed Mojave 10.14.6 on laptop HD530 (HP Pavilion 15 bc000nv)
Working:
-Bluetooth
-Ethernet
-Audio(Speakers and Headphones)
-Sleep

Not Working:
-HDMI
-Battery charging

I hope to solve at least the problem with no charging!!

Thanks in advance!!


PS: I think when i tried to install hackintosh at Sierra i had the wifi icon on post installation but on mojave no wifi card was found
Use ACPIBatteryManger.kext in Clover/Kext/Other/. And please can you tell me how much MB of graphics is showing in the About Mac section (system information)? And which wireless card you are using?
 

wolfgang

New member
Neither of this two kexts work unfortunately, battery not charging and is working only the bluetooth. I'm not using wireless card cause I'm in from ethernet. I can't find on the internet what type of wireless card is using this machine: HP Pavilion 15 bc000nv. I found for similar laptop but not from this I have. Maybe I don't look in right places!

EDIT: my laptop is 15inch but I left it in SMBIOS as 13,3
 

Attachments

Last edited:

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Neither of this two kexts work unfortunately, battery not charging and is working only the bluetooth. I'm not using wireless card cause I'm in from ethernet. I can't find on the internet what type of wireless card is using this machine: HP Pavilion 15 bc000nv. I found for similar laptop but not from this I have. Maybe I don't look in right places!

EDIT: my laptop is 15inch but I left it in SMBIOS as 13,3
As you provided the laptop specification HP Pavilion 15-bc000nv uses Intel wireless card. Intel wireless card is not supported in Hackintosh. And your battery not charging issue is a strength, can you charge it while it is off or you mean to say it charges but the indicator fails? Please explain more clearly.
 

wolfgang

New member
Hey there my friend! Firstly sorry for my bad English but i will try to explain clearly.
It says it is not charging and the battery status is stucks at 0%. If i unplug the AC Adapter a few minutes later the battery is so low that shutdown the laptop and after that i need to plug again the AC Adapter to will be able to open the laptop again.
 

Troygoon

New member
Hi, I try to send a DSDT Patch request but after entering the lines of code below, I get attached error: "syntax error near unexpected token..." after each line. Any ideas will be appreciated. Thanks

External(MDBG, MethodObj, 1)
External(_GPE.MMTB, MethodObj, 0)
External(_SB.PCI0.LPCB.H_EC.ECWT, MethodObj, 2)
External(_SB.PCI0.LPCB.H_EC.ECRD, MethodObj, 1)
External(_SB.PCI0.LPCB.H_EC.ECMD, MethodObj, 1)
External(_SB.PCI0.PEG0.PEGP.SGPO, MethodObj, 2)
External(_SB.PCI0.GFX0.DD02._BCM, MethodObj, 1)
External(_SB.PCI0.SAT0.SDSM, MethodObj, 4)
External(_GPE.VHOV, MethodObj, 3)
External(_SB.PCI0.XHC.RHUB.TPLD, MethodObj, 2)
 

Attachments

joluslol10

New member
Hi @noobsplanet, @ALiveVam ,

Here are the Terminal output, Clover and Origin attached. All the help is appreciated.

Spec :
Laptop HP Gaming ak001-np
CPU : Intel i5-6300HQ
GPU : Intel HD 530 + Nvidia GTX 950 (Mobile/Notebook)
RAM : 8GB
OS : MacOS High Sierra + Windows 10
obs: I have a dedicated disk for each one.
Installation reboots at middle of the progress I guess it’s because of the double graphics.
Best regards,
joluslol10
 

Attachments

Last edited:

drlicauco

Samsung Ultrabook 940X; NP940X3G-K02US; i5-4200
Hi,

Sorry I am new to this. I even had a hard time finding how to upload the zip files.

I have been trying to fix this Samsung since September and I am still not winning.

My system is
Samsung Ultrabook 940X (NP940X3G-K02US)
Intel i5-4200
Intel HD 4400 / HD 4600
8GB RAM
128GB SSD

1. I have been having problems getting the right Graphics... Intel HD Graphics 4400. The memory is saying it is 21 MB. And the graphics is too small. What I did to get the fonts bigger is I ran one-key-hidpi

bash -c "$(curl -fsSL https://raw.githubusercontent.com/xzhih/one-key-hidpi/master/hidpi.sh)"

This gave me a bigger text/font but I know this is wrong because I still do not get options on display to change resolutions.


2. My second problem is with the battery. Most of the time it does not appear but once in a while the battery indicator appears.

3. I had to get the battery working for me to get my trackpad working properly. I do not have any scroll with two fingers.


Your help is much appreciated.


Thank you.

 

Attachments

chanhdara

New member
Hello!
Please help me patch my laptop. The problem is as follows:
My system is:
Dell Latitude E6540
Intel i7-4800MQ
Intel HD 4600 / AMD Radeon HD 8790
16GB RAM
256GB SSD
I patched DSDT and used some of the available patches.
My problem:
- USB 3.0 not working
- Auto shutdown after sleep (login).


Thank you!.
 

Attachments

adarsh

New member
Hey,
Please help me patching my system, i don't have any knowledge of patching DSDT.
Specs:
Dell Inspiron 5567
Intel(R) Core(TM) i5-7TH GEN CPU @ 2.70GHz, 2901 Mhz, 2 Core(s), 4 Logical Processor(s)
Integrated- Intel HD Graphics 620
Dedicated- AMD Radeon R7 M445 (2GB)
RAM-4GB(DDR4)
Installed macOS Mojave on a 250gb SSD along with Windows 10 on the same SSD.

Problems:
1.Main problem is the battery issue, i have read about it and tried to patch DSDT to disable dedicated GPU but couldn't.
2.Before the system actually boots up and shows the apple logo there are a lot of scripts and then the apple logo shows up.
3.Brightness working from the preferences slider but not from the hot keys.
4. As soon as i log in, there are these two errors: Your system restarted because of an error, click ok to sign in now or wait 60s or something like this.

Thanks in advance.
 

Attachments

Top