NoobsPlanet

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics, posts and unlimited download to our resources, as well as connect with other members through your own private inbox!

HP -15ab292nr(Touch) -- Mojave HD 530 graphics says 7MB, graphics tearing

kindanoob

New member
After installing Mojave 10.14.1 on my HP Pavilion Laptop (15-ab292nr) the only problem is the Intel HD 530 graphics processor. Bluetooth etc all work.

The HD 530 registers as only 7MB memory and the scree has tearing artifacts. NOTE:


Microprocessor
Intel® Core™ i7-6700HQ with Intel® HD Graphics 530 (2.6 GHz, up to 3.5 GHz, 6 MB cache, 4 cores)​
Video Graphics
Intel® HD Graphics 520 (up to 3.95 GB)​
I have tried many, many, many things over 1 week of non-stop reading and trying.



__ Rehabman's config makes no difference BUT does this require removing Whatevergreen and Lilu.
__Whatevergreen and Lilu are the 1.4 versions in /L/E. I have tried them in Clover/kexts/Other and also in /S/L/E (just a shot)
__All sorts of ig_platform_ids: 191B0000, 19120000, 19160000, and with last digits 1, 3 or 5 Also, 0x0A260006. With and without "InjectIntel"
__Hackintool patcher output for Framebuffer.
I MUST ADMIT I DO NOT UNDERSTAND FRAMEBUFFER PATCHING. So take that into account !! :)
__Whatevergreen says "IGFX @DVMT not available on this platform". But I am not sure if I am applying the DVMT fix at all. The BIOS of the laptop has no DVMT selection, it's very limited BIOS.

Many other guides and approaches also, that I don't even remember now.

My EFI Folder is attached as .zip. I load the config_HD530.plist for the testing using Clover boot selection.


PLEASE, help !!
 

Attachments

Last edited:

noobsplanet

Well-known member
Staff member
Administrator
Moderator
After installing Mojave 10.14.1 on my HP Pavilion Laptop (15-ab292nr) the only problem is the Intel HD 530 graphics processor. Bluetooth etc all work.

The HD 530 registers as only 7MB memory and the scree has tearing artifacts. NOTE:


Microprocessor
Intel® Core™ i7-6700HQ with Intel® HD Graphics 530 (2.6 GHz, up to 3.5 GHz, 6 MB cache, 4 cores)​
Video Graphics
Intel® HD Graphics 520 (up to 3.95 GB)​
I have tried many, many, many things over 1 week of non-stop reading and trying.




__ Rehabman's config makes no difference BUT does this require removing Whatevergreen and Lilu.
__Whatevergreen and Lilu are the 1.4 versions in /L/E. I have tried them in Clover/kexts/Other and also in /S/L/E (just a shot)
__All sorts of ig_platform_ids: 191B0000, 19120000, 19160000, and with last digits 1, 3 or 5 Also, 0x0A260006. With and without "InjectIntel"
__Hackintool patcher output for Framebuffer.
I MUST ADMIT I DO NOT UNDERSTAND FRAMEBUFFER PATCHING. So take that into account !! :)
__Whatevergreen says "IGFX @DVMT not available on this platform". But I am not sure if I am applying the DVMT fix at all. The BIOS of the laptop has no DVMT selection, it's very limited BIOS.

Many other guides and approaches also, that I don't even remember now.

My EFI Folder is attached as .zip. I load the config_HD530.plist for the testing using Clover boot selection.


PLEASE, help !!
Your profile is incomplete, complete it first. And have you tried our guide?
 

kindanoob

New member
Your profile is incomplete, complete it first. And have you tried our guide?
Thank you for the reply!

Profile updated, Specs were in the wrong place.

I followed the guide for minstolensize patch before, and I redid it using a new DSDT without any unneeded fixes for graphics.
Lilu and Whatevergreen are in /S/L/E.

__With or without the patch I cannot boot without using a random FakeID (0x12345678) and "InjectIntel"
__If I boot without InjectIntel and the patch in place I get "Kextd stalling at IGPU and AppleCodecGeneric" error. I don't know why the apple codec error is there, since I just have AppleALC and no voodooHDA.
--My new config.plist is attached and the new DSDT also.

Thanks again for looking at this.
 

Attachments

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Thank you for the reply!

Profile updated, Specs were in the wrong place.

I followed the guide for minstolensize patch before, and I redid it using a new DSDT without any unneeded fixes for graphics.
Lilu and Whatevergreen are in /S/L/E.

__With or without the patch I cannot boot without using a random FakeID (0x12345678) and "InjectIntel"
__If I boot without InjectIntel and the patch in place I get "Kextd stalling at IGPU and AppleCodecGeneric" error. I don't know why the apple codec error is there, since I just have AppleALC and no voodooHDA.
--My new config.plist is attached and the new DSDT also.

Thanks again for looking at this.
why are you using the DSDT? What patches did you applied to your DSDT?? Try removing Removing the DSDT, AppleALC and VoodooHDA. You should use only one kext for audio either AppleALC or VoodooHDA. I recommend go with AppleAlc.
Use the fresh guide again with fresh config from rehabman mentioned in the guide.
 
Top