NoobsPlanet

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics, posts and unlimited download to our resources, as well as connect with other members through your own private inbox!

IGPU driver failed to load under Mojave 10.14.4 for DELL E7450 ( Graphics card:HD5500)

Tony

New member
Hello Guys,

Blow is my laptop configuration :
Type: Dell Latitude E7450 (Clover) Intel Broadwell-U -5th Generation Dell 0HPRCX
CPU: [email protected]
Graphics: Intel HD5500 (128M under win10, 64M under Bios), 1920x1080P
RAMDR3L 1600 16GB
SSD:256G
Audio: Realtek @intel High Definition Audio Controller
network: Inter Ethernet connection 1218-LM
wirlessell :Wireless 1560 802.11ac
Bluetooth:W1560 Bluetooth 4.0 LE
Bios: A20 version (UEFI boot)
MacOS: Mojave 10.14.4

I've recently installed Mojave 10.14.4 on my E7450 (Clover version is 4910), but I'm having one problem need your help .
IGPU Graphics driver failed to load and HD 5500 Graphics RAM size is only showed 7M under MacOS Mojave.

i try use some methos to fix,for example change DVMT value and some methos which come form website osxlatitude.com forums (https://osxlatitude.com/forums/topic/11276-mojave10142-install-issue-under-e7450-for-igpu-driver-failed-to-load/?tab=comments#comment-88025) , but result is still fail and got error info "busy timeout (0) IGPU" during boot , and can't enter MacOS.

Could you please give some suggestions to me for fix this problem ?

I attached my current, working Clover Folder and S/L/E Folder and L/E Folder

Thanks in advice .

BR
Tony
 

Attachments

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Hello Guys,

Blow is my laptop configuration :
Type: Dell Latitude E7450 (Clover) Intel Broadwell-U -5th Generation Dell 0HPRCX
CPU: [email protected]
Graphics: Intel HD5500 (128M under win10, 64M under Bios), 1920x1080P
RAMDR3L 1600 16GB
SSD:256G
Audio: Realtek @intel High Definition Audio Controller
network: Inter Ethernet connection 1218-LM
wirlessell :Wireless 1560 802.11ac
Bluetooth:W1560 Bluetooth 4.0 LE
Bios: A20 version (UEFI boot)
MacOS: Mojave 10.14.4

I've recently installed Mojave 10.14.4 on my E7450 (Clover version is 4910), but I'm having one problem need your help .
IGPU Graphics driver failed to load and HD 5500 Graphics RAM size is only showed 7M under MacOS Mojave.

i try use some methos to fix,for example change DVMT value and some methos which come form website osxlatitude.com forums (https://osxlatitude.com/forums/topic/11276-mojave10142-install-issue-under-e7450-for-igpu-driver-failed-to-load/?tab=comments#comment-88025) , but result is still fail and got error info "busy timeout (0) IGPU" during boot , and can't enter MacOS.

Could you please give some suggestions to me for fix this problem ?

I attached my current, working Clover Folder and S/L/E Folder and L/E Folder

Thanks in advice .

BR
Tony
Did you try our guide to fix the Intel HD 5500 Graphics? If you haven't tried then we recommend you to follow our guide. And be sure to use the latest Lilu.kext and WhateverGreen.kext, that should fix your problem. I can see many unnecessary kext that you have installed in Clover/Kexts/Other/ and as well as repeated kext in S/L/E/, which may occur conflict get stuck you at Kernel Panic.
Don't use kext until your system needs that. I recommend you to delete unnecessary kext. The only necessary kext to boot Hackintosh is FakeSMC.kext, after that install the kexts as you go.


 

Tony

New member
Hi noobsplanet,

Thank you for your reply .
Your means is : if make sure per kext which is in Other folder don't both be put into S/L/E folder and L/E folder ,isn't it ?
if need delete all files of S/L/E folder and L/E folder,isn't it?

Sorry , my native language isn't English .Maybe you need have some patience .

BR
Tony
 

Tony

New member
Hi noobsplanet,

According your suggestion, i re-install MacOS Mojave 10.14.4 in my laptop DELL E7450 , and delete unnecessary kext for Clover\kexts\Other folder , and make sure these kexts which is under Clover\kexts\Other folder don't exist in S\L\E folder or L\E folder , and i update these three kexts (Lilu.kext \ WhateverGreen.kext \ FakeSMC.kext ) to the lastest version under Clover\kexts\Other folde . then i will still got error info "busy timeout IGPU " during boot MacOS after use your config.plist .

I attached my current, working Clover Folder
Thanks in advice .

I expect your help .

BR
Tony
 

Attachments

noobsplanet

Well-known member
Staff member
Administrator
Moderator
Hi noobsplanet,

According your suggestion, i re-install MacOS Mojave 10.14.4 in my laptop DELL E7450 , and delete unnecessary kext for Clover\kexts\Other folder , and make sure these kexts which is under Clover\kexts\Other folder don't exist in S\L\E folder or L\E folder , and i update these three kexts (Lilu.kext \ WhateverGreen.kext \ FakeSMC.kext ) to the lastest version under Clover\kexts\Other folde . then i will still got error info "busy timeout IGPU " during boot MacOS after use your config.plist .

I attached my current, working Clover Folder
Thanks in advice .

I expect your help .

BR
Tony
Still duplicate of kexts are found such as VoodooHDA.kext and AppleALC.kext which is placed in Clover/Kexts/Other/ which is used for audio. (Should be used only one either go with VoodooHDA.kext or AppleALC.kext). Also, multiple Ethernet drivers are used. But error "Busy Timeout IGPU" is a K.P. usally caused when your graphics failed to load. You've not followed our guide, according to your config.plist the ig-platform-id value is set to 0x12345678, which should be 0x16260006. Kindly follow the guide as said.
Thank You!!

 

Tony

New member
Hi noobsplanet,

According your suggestion , i delete AppleALC.kext and RealteRTL8111.kext and AtherosE2200Ethernet.kext under clover\kexts\Other folder .and re-download config.plist from your website (https://noobsplanet.com/index.php?resources/intel_hd5300_5500_6000.44/) and copy it into clover folder , then open this file with clover configurator ,
then goto Graphics and Tick inject EDID , inject Intel and ig-platform-id value to 0x16260006 , and Goto Kernal and Kext Patches and click to (+) icon inside KextsToPatch table and Fill Name as AppleIntelBDWGraphicsFramebuffer Find* [HEX] as 8945C839C7764F Replace* [Hex] as 8945C839C7EB4 and comment as www.noobsplanet.com .

finally ,Save the config File > Save and exit , and reboot my laptop . the result is : i got error info " busy timeout IGPU " during boot MacOS , and can't enter MacOS ,


By the way ,
My graphics card is HD5500 , Why not is 0x16160002 or 0x16160000 , is 0x16260006 for ig-platform-id ?

BR
Tony
 

Attachments

Top