NoobsPlanet

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics, posts and unlimited download to our resources, as well as connect with other members through your own private inbox!

Mojave slow boot up and bluetooth not working

bods4522

New member
Hi guys, i am having a hackintosh mojave 10.14.5, with i7-9750h clevo laptop, changed my wifi card to bcm 94352z. Everything worked fine, but sometimes i am experiencing a slow boot up, then after logged in my bluetooth is not working. This issue get fixed when i rebuild my kextcache using terminal command. But it still happened spontaneosly. Actually this thing start happening after i tried to copy the backlight kext to clover/kext/others and the ssdt-pnlf.aml to clover/acpi/patched. But after i realized it not working i already deleted it. Any ideas why this thing happening and how to fix it? Thank you
 

noobsplanet

Active member
Staff member
Administrator
Moderator
Sorry guys i am very new to this. I failed to generate the debug. Any idea whats going on?
View attachment 1351
As @ALiveVam already mentioned it, please attach the Clover Folder, you can attach manually. Mount the EFI partition (First Link) Right Click on your Clover folder > Compress -> Upload zip here. You seem new to Hackintosh learn about EFI (short fast introduction to Clover and Config.plist from our side Second Link). And also your profile is incomplete -> Complete it first
 

noobsplanet

Active member
Staff member
Administrator
Moderator
Hi, thanks for the reply. I completed my profile and heres my clover folder. Thanks for the help
You've installed many unnecessary Kext, delete them & should speed up your system. Also can you please attach the screenshot for sudo kextcache -i /. Delete the kext at your own risk. (some kext are required to boot the system so deleting it may trap in Kernal Panic). I find below the unnecessary kext & also you have to only one kext for ethernet (Atheros, IntelMausi, RealTek8100 or RealTek8111). And also I recommend you to use AppleALC.kext instead of VoodooHDA.kext for a better sound but for using AppleALC.kext you need to set layout-id in config.plist that are linked below in this guide. Now use the SSDT-PNLF.aml into /ACPI/patched/ -> rebuild kernel cache -> Reboot -> Brightness should work. For Audio follow the below guide.

1354


 

bods4522

New member
Hi, this is my screenshoot of kextcache -i. Sorry for asking basic question, may i know how to install the ssdt-pnlf? I copied the ssdt-pnlf to clover/acpi/patched, then type the terminal command. After reboot it doesnt work, and the boot up become slow and bluetooth not working. thank you

1356
 
Last edited:

noobsplanet

Active member
Staff member
Administrator
Moderator
Hi, this is my screenshoot of kextcache -i. Sorry for asking basic question, may i know how to install the ssdt-pnlf? thank you

View attachment 1356
Wireless kexts are also installed in S/L/E/ (System/Library/Extensions) and /EFI/Clover/Kexts/Other/ as well. Don't duplicate kext, installation of kext to Clover/Kext/Other is recommended for Hackintosh. I have attached SSDT-PNLF.aml link in the above Post #6 , just download the file extract it is compressed. Mount the EFI partition -> Move SSDT-PNLF.aml to EFI -> Clover -> ACPI -> patched Folder -> Reboot system.
 

bods4522

New member
I tried copy the ssdt-pnlf.aml to clover/acpi/patched, but it doesnt work after the command n reboot. Means this doesnt apply to my system? Thank you
 

noobsplanet

Active member
Staff member
Administrator
Moderator
I tried copy the ssdt-pnlf.aml to clover/acpi/patched, but it doesnt work after the command n reboot. Means this doesnt apply to my system? Thank you
That enables the brightness control, but remember you may not be able to change the brightness from Fn+Brightness keys. Go to System Prefs -> Displays-> and do you see brightness slider?
 

bods4522

New member
That enables the brightness control, but remember you may not be able to change the brightness from Fn+Brightness keys. Go to System Prefs -> Displays-> and do you see brightness slider?
No i didnt see the sliders. I followed the guides, copy the ssdt-pnlf.aml into clover/acpi/patched, proceed the command and reboot, doesnt enable the brightness slider in system prefs
 
Top